본문 바로가기
  • 노션에서 삽질한 내용을 정리하는 블로그
자기발전소/# Network

종합 실습

by iamlucia 2020. 11. 29.

 

 

 

 

 

1. 서울 지사

1) Tiered 2 Layer (코어 계층이 없음) 

2)  빌딩 A

- Distribution 계층의 이중화 (L3스위치) 

- 1개층

- 4 Vlans(PVST, FHRP: 10,20은 왼쪽 활성화 및  30,40은 오른쪽 활성화)

3) 빌딩 B

- Distribution 계층의 이중화 없음

- 1개층

- 2 VLANS

- EC

 

2. 인터넷 접속(KT, WAN)

 

3. NAT OVERLOAD

3.3.3.2 - 3.3.3.1 (KT) 100.100.100.1 - 100.100.100.2(인터넷) 

 


L3 스위치 1번


spanning-tree mode pvst

spanning-tree vlan 10,20 priority 4096



interface FastEthernet0/1

no switchport

ip address 10.1.7.3 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/2

no switchport

ip address 10.1.8.3 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/5

no switchport

ip address 10.1.9.3 255.255.255.0

duplex auto

speed auto



interface Vlan10
ip address 10.1.1.2 255.255.255.0
standby version 2
standby 10 ip 10.1.1.1
standby 10 priority 150

!

interface Vlan20

ip address 10.1.2.2 255.255.255.0

standby version 2

standby 20 ip 10.1.2.1

standby 20 priority 150

!

interface Vlan30

ip address 10.1.3.2 255.255.255.0

standby version 2

standby 30 ip 10.1.3.1

standby 30 priority 50

!

interface Vlan40

ip address 10.1.4.2 255.255.255.0

standby version 2

standby 40 ip 10.1.4.1

standby 40 priority 50

!

router eigrp 100

network 10.0.0.0

 

L3 스위치 2번


interface FastEthernet0/1
no switchport
ip address 10.1.10.3 255.255.255.0
duplex auto
speed auto

!

interface FastEthernet0/2

no switchport

ip address 10.1.11.3 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/5

no switchport

ip address 10.1.12.3 255.255.255.0

duplex auto

speed auto



interface FastEthernet0/1
no switchport
ip address 10.1.10.3 255.255.255.0
duplex auto
speed auto

!

interface FastEthernet0/2

no switchport

ip address 10.1.11.3 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/5

no switchport

ip address 10.1.12.3 255.255.255.0

duplex auto

speed auto



interface Vlan10
ip address 10.1.1.3 255.255.255.0
standby version 2
standby 10 ip 10.1.1.1
standby 10 priority 50

!

interface Vlan20

ip address 10.1.2.3 255.255.255.0

standby version 2

standby 20 ip 10.1.2.1

standby 20 priority 50

!

interface Vlan30

ip address 10.1.3.3 255.255.255.0

standby version 2

standby 30 ip 10.1.3.1

standby 30 priority 150

standby 30 preempt

!

interface Vlan40

ip address 10.1.4.3 255.255.255.0

standby version 2

standby 30 preempt

standby 40 ip 10.1.4.1

standby 40 priority 150

standby 40 preempt

!

router eigrp 100

network 10.0.0.0

 

 

Internet Router

interface FastEthernet0/0

ip address 100.100.100.2 255.255.255.0

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.1.7.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 10.1.10.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface FastEthernet1/1

no ip address

duplex auto

speed auto

shutdown

!

router eigrp 100

redistribute static

network 10.0.0.0

auto-summary

!

ip nat pool test 100.100.100.3 100.100.100.254 netmask 255.255.255.0

ip nat inside source list 1 pool test overload

ip classless

ip route 0.0.0.0 0.0.0.0 100.100.100.1

!

ip flow-export version 9

!

!

access-list 1 permit 10.0.0.0 0.255.255.255